Профессиональные решения для 1С 8.2 Среда, 23.08.2017, 22:25
Меню сайта
Статистика

Онлайн всего: 1
Гостей: 1
Пользователей: 0
Форма входа
Поделиться ссылкой


Главная » 2013 » Октябрь » 6 » Вывод таблицы с боковыми надписями в сгруппированных разделах
12:18
Вывод таблицы с боковыми надписями в сгруппированных разделах
Бывает, что требования заказчика к печатной форме не позволяют обойтись фиксированным макетом табличного документа. Довольно часто возникает необходимость уже в сформированной таблице объединить или перекрасить ячейки, повернуть текст  и т.п. Я хочу привести простой пример объединения ячеек для вывода бокой надписи в сгруппированном разделе. Фиксированный макет здесь не подойдет, так как число строк вывода может быть произвольным. Для решения данной задачи после вывода ячеек, мы найдем области, которые пометим текстом Старт и Стоп, затем объединим эту группу ячеек и для полученной области зададим нужные параметры.
 
Достатчно простой код:

Процедура КнопкаВыполнитьНажатие(Кнопка)
    Макет=ЭтотОбъект.ПолучитьМакет("Макет");
    Ш=Макет.ПолучитьОбласть("Шапка");
    Т=Новый ТабличныйДокумент;
    Т.Вывести(Ш);
    О=Макет.ПолучитьОбласть("Строка");
    Итого=0;
    Для Сч=1 по КолСот  Цикл
        О.Параметры.нпп=Сч;
        О.Параметры.Сотрудник="Иванов "+Сч;
        О.Параметры.Сумма=1000;
        Итого=Итого+1000;
        Т.Вывести(О);
    КонецЦикла;
    П=Макет.ПолучитьОбласть("Подвал");
    П.Параметры.Итого=Итого;
    Т.Вывести(П);
    Попытка
        О1=Т.НайтиТекст("Старт");
        О2=Т.НайтиТекст("Стоп");
        Если О1<>Неопределено и О2<>Неопределено Тогда
            О=Т.Область(О1.Имя+":"+О2.Имя);
            О.Объединить();
            О.Текст="Отдел продаж";
            О.ОриентацияТекста=90;
            О.ЦветФона=webЦвета.Серый;
            О.ЦветТекста=webЦвета.Белый;
            О.ГоризонтальноеПоложение=ГоризонтальноеПоложение.Центр;
            О.ВертикальноеПоложение=ВертикальноеПоложение.Центр;
            О.Шрифт=Новый Шрифт("Arial",10,истина);
        КонецЕсли;
    Исключение
    КонецПопытки;
   
    Т.ОтображатьСетку=Ложь;
    Т.ОтображатьЗаголовки=Ложь;
    Т.Показать("Демо-таблица");
КонецПроцедуры
Процедура ПриОткрытии()
    КолСот=20;
КонецПроцедуры
 
Пример демо-обработки показан на картинке:
Таблица имеет вид:
 
Код 1С добавлен на сайт при помощи оригинальной обработки

На основе данного примера вы можете создать аналогичные и более сложные решения.  Обработка находится в каталоге файлов в разделе обработки 
ТаблицаСБоковымиНадписями.epf

Просмотров: 957 | Добавил: Programmer1C | Рейтинг: 0.0/0
Всего комментариев: 0
Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Поиск
Календарь
«  Октябрь 2013  »
ПнВтСрЧтПтСбВс
 123456
78910111213
14151617181920
21222324252627
28293031
Архив записей
Друзья сайта
  • Создать сайт
  • Современная Ароматерапия
  • Биодобавки из США
  • Заработок для web-мастера

  • Рейтинг@Mail.ru
    www.professional-1c.ru © 2017
    Бесплатный хостинг uCoz