Профессиональные решения для 1С 8.2 Суббота, 21.10.2017, 18:57
Меню сайта
Статистика

Онлайн всего: 1
Гостей: 1
Пользователей: 0
Форма входа
Поделиться ссылкой


Главная » 2013 » Октябрь » 9 » Вывод табличного документа с фоновым "водяным знаком" в 1С
22:22
Вывод табличного документа с фоновым "водяным знаком" в 1С
Немного доработаем обработку ТаблицаСБоковымиНадписями.epf 
Иногда бывает необходимость напечатать документ с фоновым рисунком. Например, вывести на платежной ведомости фоновую надпись "Предварительный расчет" или красиво оформить ценники на фоне просвечивающегося логотипа.  Задача кажется простой, но, как ни странно, многие довольно опытные программисты не могут сразу вспомнить, какой метод можно применить, через колонтитулы не получается, большой рисунок на задний план не уходит...
И все же, всё просто. Для табличного документа можно задать свойство ФоноваяКартинка.

Процедура КнопкаВыполнитьНажатие(Кнопка)
    Макет=ЭтотОбъект.ПолучитьМакет("Макет");
    Ш=Макет.ПолучитьОбласть("Шапка");
    Т=Новый ТабличныйДокумент;
    Т.Вывести(Ш);
    О=Макет.ПолучитьОбласть("Строка");
    Итого=0;
    Для Сч=1 по КолСот  Цикл
        О.Параметры.нпп=Сч;
        О.Параметры.Сотрудник="Иванов "+Сч;
        О.Параметры.Сумма=1000;
        Итого=Итого+1000;
        Т.Вывести(О);
    КонецЦикла;
    П=Макет.ПолучитьОбласть("Подвал");
    П.Параметры.Итого=Итого;
    Т.Вывести(П);
    Попытка
        О1=Т.НайтиТекст("Старт");
        О2=Т.НайтиТекст("Стоп");
        Если О1<>Неопределено и О2<>Неопределено Тогда
            О=Т.Область(О1.Имя+":"+О2.Имя);
            О.Объединить();
            О.Текст="Отдел продаж";
            О.ОриентацияТекста=90;
            О.ЦветФона=webЦвета.Серый;
            О.ЦветТекста=webЦвета.Белый;
            О.ГоризонтальноеПоложение=ГоризонтальноеПоложение.Центр;
            О.ВертикальноеПоложение=ВертикальноеПоложение.Центр;
            О.Шрифт=Новый Шрифт("Arial",10,истина);
        КонецЕсли;
    Исключение
    КонецПопытки;
   
    Т.ОтображатьСетку=Ложь;
    Т.ОтображатьЗаголовки=Ложь;
    Фон=Макет.Рисунки.Рис1.Картинка;
    Т.ФоноваяКартинка=Фон;
    Т.Показать("Демо-таблица");
КонецПроцедуры
Процедура ПриОткрытии()
    КолСот=20;
КонецПроцедуры
 
Код 1С добавлен на сайт при помощи оригинальной обработки
 
Сформированная таблица примет, к примеру, такой вид:
Хотя фоновые изображения заполняют все видимое поле, при выводе на печать они будут ограничены областью печати.
Обработку можно скачать в разделе каталог файлов ТаблицаСФоновымВодянымЗнаком.epf
Просмотров: 4959 | Добавил: Programmer1C | Рейтинг: 0.0/0
Всего комментариев: 0
Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Поиск
Календарь
«  Октябрь 2013  »
ПнВтСрЧтПтСбВс
 123456
78910111213
14151617181920
21222324252627
28293031
Архив записей
Друзья сайта
  • Создать сайт
  • Современная Ароматерапия
  • Биодобавки из США
  • Заработок для web-мастера

  • Рейтинг@Mail.ru
    www.professional-1c.ru © 2017
    Бесплатный хостинг uCoz