Преобразователь многострочного текста в строковую константу 1С - 6 Января 2014 - Профессиональные решения для 1С 8.2
      Профессиональные решения для 1С 8.2 Среда, 29.03.2017, 06:15
Меню сайта
Статистика

Онлайн всего: 1
Гостей: 1
Пользователей: 0
Форма входа
Поделиться ссылкой


Главная » 2014 » Январь » 6 » Преобразователь многострочного текста в строковую константу 1С
11:20
Преобразователь многострочного текста в строковую константу 1С

Часто бывает нужно текст скрипта или запроса преобразовать в строчную константу. Текст запроса можно преобразовать с помощью конструктора запросов, а вот текст скрипта нужно вручную дополнять символом переноса строки "|" и заменять одинарные кавычки на двойные. Предлагаю вашему вниманию обработку, которая переводит многострочный текст в строковую константу. В программном коде нет никаких хитростей, но форма дополнена цифровыми часами из предыдущей демо-обработки в качестве примера практического использования. Однако, главное, что эта обработка может оказаться вам полезной, так как сэкономит ваше время при кодировании строковых констант.


Процедура ОсновныеДействияФормыТекст1С(Кнопка)
    ТД=Новый ТекстовыйДокумент;
    Т=ЭтаФорма.ЭлементыФормы.Исходник.ПолучитьТекст();
    ТД.УстановитьТекст(Т);
    Если ТД.КоличествоСтрок()>0 Тогда
        Р=""""+СтрЗаменить(ТД.ПолучитьСтроку(1),"""","""""");
        Для Сч=2 По ТД.КоличествоСтрок() Цикл
            Р=Р+"
            ||"+СтрЗаменить(ТД.ПолучитьСтроку(Сч),"""","""""");
        КонецЦикла;
        Р=Р+"""";
    КонецЕсли;
    ЭтаФорма.ЭлементыФормы.Результат.УстановитьТекст(Р);
КонецПроцедуры

Процедура ПриОткрытии()
    ТД=Новый ТекстовыйДокумент;
    Т="<html>
    |<body scroll=no bgcolor=""#FFFBF0"">
    |<script src=""clock.js""></script>
    |<div id=""clock"">
    |<script language=""javascript"">
    |<!--
    | clock();
    | //-->
    | </script>
    |</div>
    |</body>
    |</html>";
    КВФ=КаталогВременныхФайлов();
    ДД=ЭтотОбъект.ПолучитьМакет("clock");
    ДД.Записать(КВФ+"clock.js");
    ТД.УстановитьТекст(Т);
    ТД.Записать(КВФ+"сlock.html");
    ЭтаФорма.ЭлементыФормы.ПолеHTMLДокумента1.Перейти(КВФ+"сlock.html");
КонецПроцедуры
 
Код 1С добавлен на сайт при помощи оригинальной обработки

 

Обработку можно скачать здесь  ПреобразовательТекста.epf
 
Просмотров: 985 | Добавил: Programmer1C | Рейтинг: 0.0/0
Всего комментариев: 0
Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Поиск
Календарь
«  Январь 2014  »
ПнВтСрЧтПтСбВс
  12345
6789101112
13141516171819
20212223242526
2728293031
Архив записей
Друзья сайта
  • Создать сайт
  • Современная Ароматерапия
  • Биодобавки из США
  • Заработок для web-мастера

  • Рейтинг@Mail.ru
    www.professional-1c.ru © 2017
    Бесплатный хостинг uCoz